Linuxos zenegép frissítés

Kezdőlap Fórumok SOS! Bajban vagyok Linuxos zenegép frissítés

15 bejegyzés megtekintése - 16-30 / 98
  • Szerző
    Bejegyzés
  • #2204580

    szikszair
    Felhasználó

    lilo -M /dev/sda : bash: lilo: command not founda másikra kilistázza a lilo lehetőségeket: -c, -q, -v, -i........Nincs scsi csak 2 ide csatlakozó.Asztali gépen beléptem ac11 -el konzolba, lefuttattam a lilo-t, beindult rendesen. Át a zenegépbe, LIL- megáll. Ghost újra, szerkesztem a lilo-t, majd winyó zenegépbe ott futtatom. Reménykedem....

    #2204579

    pointux
    Felhasználó

    Másik lehetőség – tehát -, hogy kihagyod a “lilo -M /dev/sda”, és úgy hagyod a konfigot, bootolsz, megkapod a konzolt, most már ismered a root jelszót és:[bash]lilo -M /dev/hda[/bash]És ebben az esetben nincs gond azzal, hogy a konfig file-okban hogy szerepeljen az eszköz: hda-ként és kész.(Talán ez a legjobb, mert itt a legkevesebb hibalehetőség.)

    #2204578

    pointux
    Felhasználó

    Ha jól értem sziszair 03 Május 2012, 15:26:47 -kori beírását (az elözményekkel együtt), akkor van 2.2 Debianja CD-n, ugyanolyan, mint a winchen lévö rendszer.Vagy félreértettem?Mert akkor azzal bootolnék, és onnan javítgatnám a lilo-t, mert ha ugyanaz, akkor nyilván ott is hda, ...

    Nyilván valami nem, mert akkor hda lenne. Vélhetően nincs is scsi csatlakozója az akkori alaplapjának, egyszerűen másképp van konfigurálva (ill. adott esetben foltozva) a kernel.

    #2204577

    pointux
    Felhasználó

    A konzolt el tudom érni, shift, beírom:ac11.Konzolt ad viszont a f.név és jelszót nem tudom, sajnos megszerezni sem.

    Akkor marad a chroot és "megszerezzük" a root jelszót is.A CD-n root jelszóval vagy bejelentkezve!Először is:[bash]mount -t proc proc /mnt/sda1/proc[/bash]Ellenőrizés: /proc tartalma /mnt/sda1/proc-ba is átkerül[bash]mount -o bind /dev /mnt/sda1/dev[/bash]Ellenőrizés: /dev tartalma azonos

    #2204576

    gendelider
    Felhasználó

    Vizsla, nem kellene kiszedetni a root password lekérdezét egyszerüen a passwd vagy a shadow fileból?

    #2204575

    gendelider
    Felhasználó

    Ha jól értem sziszair 03 Május 2012, 15:26:47 -kori beírását (az elözményekkel együtt), akkor van 2.2 Debianja CD-n, ugyanolyan, mint a winchen lévö rendszer.Vagy félreértettem?Mert akkor azzal bootolnék, és onnan javítgatnám a lilo-t, mert ha ugyanaz, akkor nyilván ott is hda, ...

    #2204574

    szikszair
    Felhasználó

    A konzolt el tudom érni, shift, beírom:ac11.Konzolt ad viszont a f.név és jelszót nem tudom, sajnos megszerezni sem.Átírok mindent, ahogy írtad, lilo futtatásra:bash: lilo: command not foundAz egyik vinyóra ráhúztam a puppy-t, beindul vele, zene szól, csak az eredeti lejátszót nem tudom autorun-ba tenni. Meg lehet oldani, hogy a linux elindul, majd autómatikusan a lejátszó? Ha így működne...... nem szívnánk tovább a tetű lilo-val

    #2204573

    pointux
    Felhasználó

    Mivel System.map-ok nincsenek, ezért egy kernel panic esetén szinte esélytelen lesz kideríteni, hogy adott esetben mi a gond.Viszont felvetődött bennem egy kérdés. Ezek a kernelek hogy lettek frissítve? (Mert adott esetben előfordulhat, hogy semmilyen extra driver nem kell. Így akár adott esetben a frissítés is könnyebb lenne. De ez mellékes.)Illetve egy másik kérdés. Ez már fontosabb. Ezek szerint el tudod érni a konzolt egy működő rendszer alól?Mert akkor, ha a shift-es módszer még működne, akkor nem kell chrootolnunk.Hagyod a konfigurációs file-t, ahogy megírtam (illetve arra szerkeszted át) és kiadod konzolon a lilo -M /dev/hda parancsot és elvileg rendezve lenne a probléma és 18-as verziójú kerneled indulna azonnal... a legközelebbi indítástól.

    #2204572

    szikszair
    Felhasználó

    Ez egy teljesen eredeti, általam érintetlen rendszerről készült, most így néz ki:fstab:# /etc/fstab: static file system information.##

    #2204571

    pointux
    Felhasználó

    Nem értem én hogy mi is lehet ott, szóval :felcsatood live cd-ről, majd mount dev és proc, majd chroot /mnt/sdaEddig

    #2204570

    pointux
    Felhasználó

    /boot itt található: /mnt/sda1/boot , a gyökérben nincs. Itt a hda ki kell javítani lilo.conf-ban sda - ra, különben: No such device or address.System.map nem tudom hol lehet, csak map van.Átmásolom, mindent, akkor futtatásnál: Trying to map files from unnamed device 0x000d (NFS ?) üzenet fogad, ezzel zár. Újraindítás után megint nincs /boot.

    Nos, tehát mégegyszer:- a merevlemezeden lévő régi kernel: /dev/hda néven hivatkozik a merevlemezedre, amíg a CD-n lévő új típusú /dev/sda néven- a merevlemezeden lévő rendszer a merevlemezt /-ként fogja csatolni, a CD ezt /mnt/sda1-ként, így, ami a merevlemezen /boot lesz, az a CD-vel való bootoláskor /mnt/sda1/boot és ami a CD-n boot, az a merevlemezen nem fog megjelenni, mert az a memóriában vanEz most nem azt jelenti, hogy megint össze-vissza átírogatsz mindent!Azért kell a chroot, hogy a régi lilo program verzióját és az eredeti merevlemez struktúrát kapd vissza. És akkor már csak az sda/hda kérdés marad, ami a konfigurációs file-ban kétszer szerepel mindössze és számomra már nem tisztázott, hogy a jelenlegi, vagy a telepített állapotot hivatott jelölni. Ugyanis a merevlemezről történő bootolás során meg már nem lesz sda. És semmi kedvem nem is volt utánanézni, amikor egy pár mp átírni és ki lehet próbálni mindkettőt. Az az egy biztos, hogy a lilot a merevlemezbe lilo -M /dev/sda paranccsal kel telepíteni, de még itt nem tartunk. Egyelőre azt kéne ellenőrizni, hogy megvannak-e a szükséges file-ok.CD-ről bootolva:[bash]ls -l /mnt/sda1/boot > /mnt/sda1/boot.txt[/bash]Így a merevlemez gyökerében lesz egy boot.txt, ezt ide csatold fel mert akkor megnézzük milyen kernel file-jaid vannak.

    #2204569

    sk-skuba
    Felhasználó

    Nem értem én hogy mi is lehet ott, szóval :felcsatood live cd-ről, majd mount dev és proc, majd chroot /mnt/sdaEddig

    #2204568

    szikszair
    Felhasználó

    /boot itt található: /mnt/sda1/boot , a gyökérben nincs. Itt a hda ki kell javítani lilo.conf-ban sda - ra, különben: No such device or address.System.map nem tudom hol lehet, csak map van.Átmásolom, mindent, akkor futtatásnál: Trying to map files from unnamed device 0x000d (NFS ?) üzenet fogad, ezzel zár. Újraindítás után megint nincs /boot.

    #2204567

    pointux
    Felhasználó

    Mi lenne, ha ráhúznék egy komplett linuxot, ami beindul az sda1-re, sda5 maradnak a zenék, sda6 partíción van egy indit nevű fájl, ezt valahogy megadnám, hogy bekapcsolás után linux, majd automatikusan induljon. Ez lehet a lejátszó program indítója.Ezt meg lehet csinálni?

    Nem, mert a lejátszó programodnak nincs meg a forrása, így egy új linux-szal nem feltétlenül indulna. Nem is beszélve arról, hogy elképzelhető (bár ez sem feltétlenül igaz), hogy speciális driverek kellenek a lejátszóhoz, melyek neked nincsenek meg ill. nem kompatibilisek esetleg a kernellel.Persze, ha minden megvan forrásban és a driver ragasztója, vagy egésze, vagy, ha nincs szükség rá, akkor minden további nélkül.Ill., ha csak a lejátszó nincs meg, akkor nyilván lehet írni egyet hosszú szórakozással, vagy adott tudással.Neked egyiket sem javasolnám, mert mind bonyolultabb eljárás lenne a jelenleginél. A legutolsónál meg gondolom meg is kérnék rendesen az árát.

    #2204566

    pointux
    Felhasználó

    Az a legtisztább, ha ghosttal újrateszed. 🙂Ha most csak egy kernelt akarsz(nem is nagyon kell más), akkor a /boot/vmlinuz-2.2.18és/boot/System.map-2.2.18file-okra lesz szükség, ezek legyenek meg.És erre a konfigra:

    boot=/dev/hdainstall=/boot/boot.bmap=/boot/mapvga=normaldelay=0default=linuximage=/boot/vmlinuz-2.2.18

15 bejegyzés megtekintése - 16-30 / 98
  • Be kell jelentkezni a hozzászóláshoz.