BalckPanther 5.2.8 JAVA probléma

Kezdőlap Fórumok blackPanther OS BalckPanther 5.2.8 JAVA probléma

9 bejegyzés megtekintése - 1-9 / 9
  • Szerző
    Bejegyzés
  • #1890465
    lapatyo
    Felhasználó

    Üdv!A fenti disztro ketyeg egy nagyon régi, P3-on, amivel teljesen elégedett vagyok, a célnak megfelel. A JAVA alkalmazást frissítettem "jre-7u7-linux-i586.rpm" csomagot telepítettem. Tökéletesen feltelepült, de azóta a Firefox-szal nem tudok JAVA alkalmazást indítani. Valaki tud ebben segíteni?Köszönöüm!

    #2205473
    pointux
    Felhasználó

    Sajnos nem hozta semmi létre a firefoxnak a plugin linkjét és a firefox nem tudja hol van. Általános megoldás:Nyiss meg mondjuk egy mc-t és hozz létre egy szimbolikus linket a [firefox könyvtár]/plugins könyvtárba a [jre könyvtár]/lib/[arch]/libnpjp2.so file-ról. (kurzor ez utóbbin, másik panelon a másik könyvtár és parancs > Simb. link)az [x könyvtár], az x elérési útvonala, természetesenaz arch meg i386/amd64Ha csak egy felhasználónak kell, akkor ez a firefox könyvtár lehet a saját könyvtárad is pl. ~/.mozilla

    #2205474
    Angel
    Felhasználó

    Hat nem biztos hogy a linkeles megoldja mivel egy nagyon regi rendszeren akar egy nagyon uj keretrendszert futtatni.Provald a javat siman futtarni konzolbol, erre mit mond?echo $JAVA_HOMEjava -version

    #2205475
    lapatyo
    Felhasználó

    Amit pointux írt, az a megoldás, olvastam már valahol forumokon. Az a baj azzal csupán az, hogy én mezei “júzer” vagyok, kicsit ez a labda magas nekem. A menetét ha leírnád, azt megköszönném!

    #2205476
    pointux
    Felhasználó

    A “echo $JAVA_HOME” megadja az aktuális java könyvtár útvonalát, vagy linkjét, ha támogatott a váltogatás.A "java -version" megadja az aktuális verziót és az architektúrát. És talán utal arra, hogy egyáltalán fog-e működni, mint ahogy utalást kaptunk rá.Azaz ezek a kimenetek eléggé hasznosak lehetnek. 🙂A firefox könyvtárat megintcsak nem tudom, de a "~/.mozilla/plugins" felhasználói szinten működnie kell, úgyhogy azzal az új infók alapján konkrét linkelő parancsot (ln) parancsot tudunk beírni.

    #2205477
    sk-skuba
    Felhasználó

    Nem a /usr/share/mozilla/plugins/ ?

    #2205478
    pointux
    Felhasználó

    Nem feltétlenül, lehet éppen pl. /opt/firefox/plugins is. Ha eredeti bp csomag, akkor biztosra meg lehet mondani, de a home könyvtárnak mindenképpen működnie kell. 🙂

    #2205479
    lapatyo
    Felhasználó

    Köszönöm Mindenkinek, sikerült a linket is megcsinálni, elindul a JAVA, de nem működik. Valószínű azért, mert ezen a disztron már nem fut az új 1.7.0 07-es verzió? Melyik lenne jó ehhez?Köszönöm!

    #2205480
    Angel
    Felhasználó

    Erre noncs helyes valasz, menni kell visszafele a verziokkal. Amelyik megy az a jo;)

9 bejegyzés megtekintése - 1-9 / 9
  • Be kell jelentkezni a hozzászóláshoz.